ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14055. ЕГКР 2026

Операнды арифметического выражения записаны в системе счисления с основанием 23.

761x03523 + 338x93223

В записи чисел переменной х обозначена неизвестная цифра из алфавита 23-ричной системы счисления. Определите наименьшее значение х, при котором значение данного арифметического выражения кратно 22.

Для найденного х вычислите частное от деления значения арифметического выражения на 22 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:23]:
    num_1 = int(f'761{x}035', 23)
    num_2 = int(f'338{x}932', 23)
    num = num_1 + num_2
    if num % 22 == 0:
        ans.append([x, num // 22])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие