ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14054. Досрочная волна 2026

Значение арифметического выражения

2 ∙ 2187567 + 729566 – 2 ∙ 243565 + 81564 – 2 ∙ 27563 – 6561

записали в системе счисления с основанием 27. Определите в 27-ричной записи числа количество цифр с чётным числовым значением, превышающим 9.

num = 2*2187**567 + 729**566 - 2*243**565 + 81**564 - 2*27**563 - 6561

cnt = 0
while num:
    if num % 27 % 2 == 0 and num % 27 > 9: cnt += 1
    num //= 27

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие