ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14053. Апробация 2026

Операнды арифметического выражения записаны в системе счисления с основанием 22.

12313x5722 + 1x3456122

В записи чисел переменной х обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наибольшее значение х, при котором значение данного арифметического выражения кратно 21.

Для найденного х вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:22]:
    num_1 = int(f'12313{x}57', 22)
    num_2 = int(f'1{x}34561', 22)
    num = num_1 + num_2
    if num % 21 == 0:
        ans.append([x, num // 21])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие