ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14062. Демоверсия 2027

Операнды арифметического выражения записаны в системе счисления с основанием 22.

27x9887622 + 26x5122 + 711x522

В записи чисел переменной x обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 21.

Для найденного x вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно

from string import printable as alph

ans = []
for x in alph[:22]:
    num_1 = int(f'27{x}98876', 22)
    num_2 = int(f'26{x}51', 22)
    num_3 = int(f'711{x}5', 22)
    num = num_1 + num_2 + num_3
    if num % 21 == 0:
        ans.append([x, num // 21])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие