ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14048. Демоверсия 2026

Значение арифметического выражения

2 ∙ 21872020 + 7292021 – 2 ∙ 2432022 + 812023 – 2 ∙ 272024 – 6561

записали в системе счисления с основанием 27. Определите в 27-ричной записи числа количество цифр с числовым значением, превышающим 9.

num = 2*2187**2020 + 729**2021 - 2*243**2022 + 81**2023 - 2*27**2024 - 6561

cnt = 0
while num:
    if num % 27 > 9: cnt += 1
    num //= 27

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие