ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14049. Демоверсия 2026

Операнды арифметического выражения записаны в системе счисления с основанием 29.

923x87429 + 524x615229

В записи чисел переменной x обозначена неизвестная цифра из алфавита 29-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 28.

Для найденного x вычислите частное от деления значения арифметического выражения на 28 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:29]:
    num_1 = int(f'923{x}874', 29)
    num_2 = int(f'524{x}6152', 29)
    num = num_1 + num_2
    if num % 28 == 0:
        ans.append([x, num // 28])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие