ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14047. Пересдача 2025

Значение арифметического выражения 7 ∙ 9210 + 6 ∙ 9110 – x, где x - целое положительное число, не превышающее 2400, записали в девятеричной системе счисления.

Определите наибольшее значение x, при котором в девятеричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 100 нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2401):
    num = 7*9**210 + 6*9**110 - x
    cnt = 0
    while num:
        if num % 9 == 0: cnt += 1
        num //= 9
    if cnt == 100:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие