ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14046. Резервная волна 2025

Операнды арифметического выражения записаны в системе счисления с основанием 30.

7xA9F30 + 1B3x30

В записи чисел переменной x обозначена неизвестная цифра из алфавита 30-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 29.

Для найденного x вычислите частное от деления значения арифметического выражения на 29 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:30]:
    num_1 = int(f'7{x}A9F', 30)
    num_2 = int(f'1B3{x}', 30)
    num = num_1 + num_2
    if num % 29 == 0:
        ans.append([x, num // 29])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие