ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14045. Резервная волна 2025

Значение арифметического выражения

2 ∙ 2401525 + 3 ∙ 343524 – 4 ∙ 49523 + 5 ∙ 49522 – 6 ∙ 7521 – 35

записали в системе счисления с основанием 49. Определите в 49-ричной записи числа количество цифр с числовым значением, не превышающим 9.

num = 2*2401**525 + 3*343**524 - 4*49**523 + 5*49**522 - 6*7**521 - 35

cnt = 0
while num:
    if num % 49 <= 9: cnt += 1
    num //= 49

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие