ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14033. Основная волна 2024

Значение арифметического выражения 6260 + 6160 + 660 – x, где x – целое положительное число, не превышающее 2030, записали в 6-ричной системе счисления.

Определите наибольшее значение x, при котором количество нулей в 6-ричной записи числа, являющегося значением данного арифметического выражения, равно 202.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2031):
    num = 6**260 + 6**160 + 6**60 - x
    cnt = 0
    while num:
        if num % 6 == 0: cnt += 1
        num //= 6
    if cnt == 202:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие