ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14032. Основная волна 2024

Значение арифметического выражения 62030 + 6100 – x, где x – целое положительное число, не превышающее 2030, записали в 6-ричной системе счисления.

Определите наибольшее количество нулей, которое может содержать число, являющееся 6-ричной записью значения данного арифметического выражения.

ans = []
for x in range(1, 2031):
    num = 6**2030 + 6**100 - x
    cnt = 0
    while num:
        if num % 6 == 0: cnt += 1
        num //= 6
    ans.append(cnt)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие