ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14035. Демоверсия 2025

Значение арифметического выражения

3 ∙ 31258 + 2 ∙ 6257 – 4 ∙ 6256 + 3 ∙ 1255 – 2 ∙ 254 – 2025

записали в системе счисления с основанием 25. Сколько значащих нулей содержится в этой записи?

num = 3*3125**8 + 2*625**7 - 4*625**6 + 3*125**5 - 2*25**4 - 2025

cnt = 0
while num:
    if num % 25 == 0: cnt += 1
    num //= 25
    
print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие