ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14025. ЕГКР

Значение арифметического выражения 3 ⋅ 279 + 2 ⋅ 276 + 273 − x, где х — целое положительное число, не превышающее 27 000, записали в 27-ричной системе счисления.

Определите наименьшее значение х, при котором в 27-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 6 нулей.

В ответе запишите число в десятичной системе счисления.

for x in range(1, 27_000):
    # Выражение
    num = 3 * 27**9 + 2 * 27**6 + 27**3 - x
    # Подсчёт нулей
    count = 0
    # Поиск нулей в 27-чной записи
    while num:
        if num % 27 == 0:
            count += 1
        num //= 27
    # Если ровно 6 нулей
    if count == 6:
        # Выводим x
        print(x)
        # Завершаем цикл
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие