ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14024. ЕГКР 2024

Определите количество ненулевых цифр в девятеричной записи числа

2 ∙ 729333 + 2 ∙ 243334 – 81335 + 2 ∙ 27336 – 2 ∙ 9337 – 338

num = 2*729**333 + 2*243**334 - 81**335 + 2*27**336 - 2*9**337 - 338

cnt = 0
while num:
    if num % 9 != 0: cnt += 1
    num //= 9

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие