ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14023. Демоверсия

Значение арифметического выражения 9 ⋅ 11210 + 8 ⋅ 11150 – x, где x – целое положительное число, не превышающее 3000, записали в 11-ричной системе счисления.

Определите наибольшее значение x, при котором в 11-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 60 нулей.

В ответе запишите число в десятичной системе счисления.

def count_zero(num, sys):
    count = 0
    while num:
        if num % sys == 0:
            count += 1
        num //= sys
    return count


for x in range(1, 3_000)[::-1]:
    num = 9 * 11 ** 210 + 8 * 11 ** 150 - x
    if count_zero(num, 11) == 60:
        print(x)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие