ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14022. Демоверсия

Операнды арифметического выражения записаны в системе счисления с основанием 29.

923×87429 + 524×615229

В записи чисел переменной х обозначена неизвестная цифра из алфавита 29-ричной системы счисления.

Определите наибольшее значение х, при котором значение данного арифметического выражения кратно 28.

Для найденного х вычислите частное от деления значения арифметического выражения на 28 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable

for x in printable[:29][::-1]:
    n1 = int(f'923{x}874', 29)
    n2 = int(f'524{x}6152', 29)
    res = n1 + n2
    if res % 28 == 0:
        print(res // 28)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие