ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14026. Досрочная волна 2024

Операнды арифметического выражения записаны в системе счисления с основанием 27:

123x2427 + 135x7827

В записи чисел переменной x обозначена неизвестная цифра из алфавита 27-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 26.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 26 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:27]:
    num_1 = int(f'123{x}24', 27)
    num_2 = int(f'135{x}78', 27)
    num = num_1 + num_2
    if num % 26 == 0:
        ans.append([x, num // 26])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие