ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14016. Досрочная волна 2023

Операнды арифметического выражения записаны в системе счисления с основанием 15.

97968x1315 + 7x21315

В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 14.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:15]:
    num_1 = int(f'97968{x}13', 15)
    num_2 = int(f'7{x}213', 15)
    num = num_1 + num_2
    if num % 14 == 0:
        ans.append([x, num // 14])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие