ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14015. ФИПИ 2023

Значение арифметического выражения

343515 – 6 ∙ 49520 + 5 ∙ 49510 – 3 ∙ 7530 – 550

записали в системе счисления с основанием 7. Определите количество цифр 6 в записи этого числа.

num = 343**515 - 6*49**520 + 5*49**510 - 3*7**530 - 550

cnt = 0
while num:
    if num % 7 == 6: cnt += 1
    num //= 7

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие