ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14005. Досрочная волна

Операнды арифметического выражения записаны в системе счисления с основанием 27:

123x2427 + 135x7827

В записи чисел переменной x обозначена неизвестная цифра из алфавита 27-ричной системы счисления.

Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 26.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 26 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import digits, ascii_uppercase

alph = digits + ascii_uppercase

# Перебираем значения x от наибольшего
for x in alph[:27][::-1]:
    # 123x24
    n1 = int(f'123{x}24', 27)
    # 135x78
    n2 = int(f'135{x}78', 27)
    # Выражение целиком
    res = n1 + n2
    # Если значение кратно 26
    if res % 26 == 0:
        # Частное от деления на 26
        print(res // 26)
        # Завершаем цикл
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие