ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14004. Демоверсия

Операнды арифметического выражения записаны в системе счисления с основанием 19:

98897x2119 + 2x92319

В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления.

Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18.

Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import digits, ascii_uppercase

alph = digits + ascii_uppercase

# Перебираем значения x от наибольшего
for x in alph[:19][::-1]:
    # 98897x21
    n1 = int(f'98897{x}21', 19)
    # 2x923
    n2 = int(f'2{x}923', 19)
    # Выражение целиком
    res = n1 + n2
    # Если значение кратно 18
    if res % 18 == 0:
        # Частное от деления на 18
        print(res // 18)
        # Завершаем цикл
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие