ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14003. Демоверсия 2022

Значение арифметического выражения

3 ∙ 438 + 2 ∙ 423 + 420 + 3 ∙ 45 + 2 ∙ 44 + 1

записали в системе счисления с основанием 16. Сколько значащих нулей содержится в этой записи?

num = 3*4**38 + 2*4**23 + 4**20 + 3*4**5 + 2*4**4 + 1
cnt = 0
while num:
    if num % 16 == 0: cnt += 1
    num //= 16
print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие