ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14002. Основная волна 2021

Результат выражения

4 ∙ 6259 − 2515 + 2 ∙ 511 − 7

записали в 5-ричной системе счисления. Сколько цифр 4 в получившейся записи?

num = 4*625**9 - 25**15 + 2*5**11 - 7

cnt = 0
while num:
    if num % 5 == 4: cnt += 1
    num //= 5

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие