ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14006. ЕГКР

Значение арифметического выражения   3100 — x, где x – целое положительное число, не превышающее 2030, записали в троичной системе счисления.

Определите наибольшее значение x, при котором количество нулей в троичной записи числа, являющегося значением данного арифметического выражения, максимально.

В ответе запишите число в десятичной системе счисления.

# Подсчёт нулей (функция)
def count_zero(num):
    count = 0
    # Поиск нулей в 3-чной записи
    while num:
        if num % 3 == 0:
            count += 1
        num //= 3
    return count


res = []
for x in range(1, 2031):
    num = 3 ** 100 - x
    count = count_zero(num)
    res.append((count, x))

print(max(res)[1])
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие