ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9201. Авторская задача

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите наибольший номер строки таблицы, для чисел которой выполнены оба условия:

– наибольшее из четырёх чисел больше суммы трёх других;
 – все числа различны.

В ответе запишите только число.

with open('931.txt') as f:
    data = [list(map(int, i.split())) for i in f]

def f1(arr):
    mx = max(arr)
    return mx > sum(arr) - mx


def f2(arr):
    cnt = [arr.count(num) for num in set(arr)]
    return sorted(cnt) == [1, 1, 1, 1]



for idx, line in list(enumerate(data, start=1))[::-1]:
    if f1(line) and f2(line):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие