ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9113. Типовая задача

Откройте файл электронной таблицы, содержащей вещественные числа — результаты ежечасного измерения концентрации примесей в воде очистных установок на протяжении трёх месяцев.

Найдите разность между минимальным значением концентрации примесей на протяжении трёх месяцев и средним арифметическим значением концентрации примесей в этот период времени.

В ответ запишите только целую часть получившегося числа.

from statistics import mean
data = []
with open('928.txt') as f:
    next(f)
    for line in f:
        parts = line.replace(',', '.').split()
        numbers = list(map(float, parts[1:]))
        data.extend(numbers)

mn = min(data)
mean_val = mean(data)

print(int(mean_val - mn))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие