ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9114. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите наименьший номер строки таблицы, для чисел которой выполнены оба условия:

– в строке одно число повторяется четыре раза, остальные три различны;
 – сумма неповторяющихся чисел строки меньше суммы её повторяющихся чисел.

В ответе запишите только число.

with open('929.txt') as f:
    data = [list(map(int, i.split())) for i in f]

def f1(arr):
    cnt = [arr.count(num) for num in set(arr)]
    return sorted(cnt) == [1, 1, 1, 4]


def f2(arr):
    no_rep = [i for i in arr if arr.count(i) == 1]
    rep_4 = [i for i in arr if arr.count(i) == 4]
    return sum(no_rep) < sum(rep_4)


for idx, line in list(enumerate(data, start=1)):
    if f1(line) and f2(line):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие