ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9111. Типовая задача

Откройте файл электронной таблицы, содержащей вещественные числа — результаты ежечасного измерения концентрации примесей в воде очистных установок на протяжении трёх месяцев.

Найдите количество значений концентраций, не совпадающих по значению ни с тремя минимальными, ни с тремя максимальными значениями, полученными за весь период наблюдений.

data = []
with open('926.txt') as f:
    next(f)
    for line in f:
        parts = line.replace(',', '.').split()
        numbers = list(map(float, parts[1:]))
        data.extend(numbers)

unique_sorted = sorted(set(data))

min3_values = set(unique_sorted[:3])
max3_values = set(unique_sorted[-3:])

forbidden = min3_values | max3_values
count = len(data) - sum(data.count(val) for val in forbidden)
print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие