ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9110. Типовая задача

Откройте файл электронной таблицы, содержащей вещественные числа — результаты ежечасного измерения концентрации примесей в воде очистных установок на протяжении трёх месяцев.

Найдите процентное содержание значений концентраций, превышающих 9,0, среди значений концентраций, попадающих в диапазон от 6,0 (включительно) до 14,0 (включительно).

В ответ запишите только целую часть получившегося числа.

data = []
with open('925.txt') as f:
    next(f)
    for line in f:
        parts = line.replace(',', '.').split()
        numbers = list(map(float, parts[1:]))
        data.extend(numbers)

in_range = [x for x in data if 6.0 <= x <= 14.0]
more_9 = [x for x in in_range if x > 9.0]

percent = (len(more_9) / len(in_range)) * 100
print(int(percent))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие