ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9042. ЕГКР 2026

Откройте файл электронной таблицы, содержащей в каждой строке семь целых чисел. Определить количество строк таблицы, для которых выполнены оба условия:

– в строке одно число повторяется трижды, остальные числа различны;
 – максимальное число строки не повторяется.

В ответе запишите только число.

with open('918.txt') as f:
    data = [list(map(int, i.split())) for i in f]

cnt = 0
for idx, line in list(enumerate(data, start=1))[::-1]:
    cnt_3 = [i for i in line if line.count(i) == 3]
    cnt_1 = [i for i in line if line.count(i) == 1]
    max_num = max(line)
    if len(cnt_3) == 3 and len(cnt_1) == 4 and line.count(max_num) == 1:
        cnt += 1

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие