ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9041. Демоверсия 2026

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите сумму чисел в строке с наибольшим номером, для которой выполнены оба условия:

– в строке есть одно число, которое повторяется трижды, остальные четыре числа различны;
 – среднее арифметическое неповторяющихся чисел строки не больше повторяющегося числа.

В ответе запишите только число.

from statistics import mean

with open('914.txt') as f:
    data = [list(map(int, i.split())) for i in f]

for line in data[::-1]:
    # Повторяются 3 раза
    cnt_3 = [i for i in line if line.count(i) == 3]
    # Повторяются 1 раз
    cnt_1 = [i for i in line if line.count(i) == 1]
    if len(cnt_3) == 3 and len(cnt_1) == 4 and mean(cnt_1) <= cnt_3[0]:
        print(sum(line))
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие