ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6111. Типовая задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 18 [Вперёд 19 Направо 60]

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

import math as m
from turtle import *

# Базовая настройка
tracer(0)  # Отключаем анимацию

# Переменные
angles = []
coords = []
count = 0

lt(90)

# Алгоритм
for i in range(21):
    if i < 6:
        angles.append(heading())
        coords.append((xcor(), ycor()))
    fd(19)
    rt(60)

k_2 = round(m.tan(m.radians(angles[1])), 8)
k_3 = round(m.tan(m.radians(angles[2])), 8)

b_2 = coords[1][1] - k_2 * coords[1][0]
b_3 = coords[2][1] - k_3 * coords[2][0]
b_5 = coords[4][1] - k_2 * coords[4][0]
b_6 = coords[5][1] - k_3 * coords[5][0]

for x in range(1, 33):
    for y in range(-10, 29):
        if k_2 * x + b_5 < y < k_2 * x + b_2 and 
                k_3 * x + b_6 < y < k_3 * x + b_3:
            count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие