ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6034. Резервная волна 2025

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 3 [Вперёд 39 Направо 90 Вперёд 48 Направо 90]
Поднять хвост
Вперёд 27 Направо 90 Вперёд 24 Налево 90
Опустить хвост
Повтори 3 [Вперёд 29 Направо 90 Назад 18 Направо 90]

Определите площадь области объединения фигур, ограниченных заданными алгоритмом линиями

from turtle import *

tracer(0)
pensize(5)

scale = 15
dot_size = 8
dot_color = "#FFF"
screensize(2000, 2000)

lt(90)

color("#A7D380")

for _ in range(3):
    fd(39 * scale)
    rt(90)
    fd(48 * scale)
    rt(90)

pu()
fd(27 * scale)
rt(90)
fd(24 * scale)
lt(90)
pd()

color("#F76D47")

for _ in range(3):
    fd(29 * scale)
    rt(90)
    bk(18 * scale)
    rt(90)

pu()

for x in range(0, 50):
    for y in range(-20, 50):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(39 * 48 + 29 * 18 - 18 * 12)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие