ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6032. Основная волна 2025

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 2 [Вперёд 3 Направо 90 Вперёд 20 Направо 90]
Поднять хвост
Назад 8 Направо 90 Вперёд 9 Налево 90
Опустить хвост
Повтори 2 [Вперёд 16 Направо 90 Вперёд 8 Направо 90]

Определите, сколько точек с целочисленными координатами находится внутри объединения фигур, ограниченного заданными алгоритмом линиями, включая точки на линиях.

from turtle import *

tracer(0)
pensize(3)

scale = 30
dot_size = 4
dot_color = "#696969"
screensize(2000, 2000)

lt(90)

color("#A7D380")

for _ in range(2):
    fd(3 * scale)
    rt(90)
    fd(20 * scale)
    rt(90)

pu()
bk(8 * scale)
rt(90)
fd(9 * scale)
lt(90)
pd()

color("#F76D47")

for _ in range(2):
    fd(16 * scale)
    rt(90)
    fd(8 * scale)
    rt(90)

pu()


for x in range(0, 21):
    for y in range(-8, 9):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(4*21 + 17* 9 - 4 * 9)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие