ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6027. Апробация 2025

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 3 [Вперёд 27 Направо 90 Вперёд 12 Направо 90]
Поднять хвост
Вперёд 4 Направо 90 Вперёд 6 Налево 90
Опустить хвост
Повтори 4 [Вперёд 83 Направо 90 Вперёд 77 Направо 90] 

Определите, сколько точек с целочисленными координатами будут находиться внутри объединения фигур, ограниченных заданными алгоритмом линиями, включая точки на границах этого объединения.

from turtle import *

# Базовая настройка
tracer(0)  # Отключаем анимацию
pensize(6)  # Размер пера
screensize(2500, 2500)  # Размер окна

scale = 40  # Масштаб
dot_size = 5  # Размер точек
dot_color = "#696969"  # Цвет точек

lt(90)  # Поворот по положительному направлению оси ординат

color("#A7D380")  # Цвет границ первой фигуры

# Первая фигура
for i in range(3):
    fd(27 * scale)
    rt(90)
    fd(12 * scale)
    rt(90)

# Перемещение
up()
fd(4 * scale)
rt(90)
fd(6 * scale)
lt(90)
down()

color("#F76D47")  # Цвет границ второй фигуры

# Вторая фигура
for i in range(4):
    fd(83 * scale)
    rt(90)
    fd(77 * scale)
    rt(90)

# Точки
up()
for x in range(0, 7):
    for y in range(0, 24):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)
        
print(28 * 13 + 84 * 78 - 7 * 24)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие