ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24027. Основная волна 2024

Текстовый файл состоит из символов A, B, C, D, E и F.

Определите максимальное количество идущих подряд символов в прилагаемом файле, среди которых пара символов CD (в указанном порядке) встречается ровно 160 раз.

with open('2403.txt', 'r') as file:
    data = file.readline()

data = data.replace("CD", "C D").split()

length = 0

for i in range(len(data) - 160):
    substring = "".join(data[i:i + 161])
    length = max(length, len(substring))
print(length)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие