ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 2034. Апробация 2025

Миша заполнял таблицу истинности логической функции F =  (w → ¬(z → x)) ∨ y, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

F
1 0
0 1 0 0
0 0

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

from itertools import product, permutations


def f(x, y, z, w):
    return (w <= (not (z <= x))) or y


for i in product([0, 1], repeat=7):
    table = [(1, i[0], i[1], i[2]), (0, 1, 0, i[3]),
             (i[4], 0, i[5], i[6])]
    if len(table) == len(set(table)):
        for p in permutations('xyzw'):
            u = [f(**dict(zip(p, t))) for t in table]
            if u == [0, 0, 0]:
                print(*p)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие