ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 2018. Апробация 2023

Миша заполнял таблицу истинности логической функции F = ((w → y) → (x ≡ y)) ∨ ¬z, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

F
0 1 0 0
0 0 0
1 1 0

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

from itertools import product, permutations


def f(w, x, y, z):
    return ((w <= y) <= (x == y)) or not z


for i in product([0, 1], repeat=5):
    table = [
        (i[0], 0, 1, 0),
        (0, i[1], i[2], 0),
        (i[3], 1, 1, i[4])
    ]
    if len(table) == len(set(table)):
        for title in permutations('wxyz'):
            check = [f(**dict(zip(title, row))) for row in table] == [0, 0, 0]
            if check:
                print(*title, sep='')

Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие