ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 2017. Досрочная волна 2023

Миша заполнял таблицу истинности логической функции F = ¬(y ∧ ¬x) ∧ ¬(x ≡ z) ∧ w, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

F
0 0 1 1
0 1 0 1 1
0 1

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

from itertools import product, permutations


def f(w, x, y, z):
    return not (y and not x) and not (x == z) and w


for i in product([0, 1], repeat=4):
    table = [
        (0, 0, i[0], 1),
        (0, 1, 0, 1),
        (i[1], i[2], 0, i[3])
    ]
    if len(table) == len(set(table)):
        for title in permutations('wxyz'):
            check = [f(**dict(zip(title, row))) for row in table] == [1, 1, 1]
            if check:
                print(*title, sep='')

Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие