ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17103. Типовая задача

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от -100 000 до 100 000 включительно.

Определите количество троек элементов последовательности, в которых не менее двух из трёх элементов являются двузначными числами, а сумма элементов тройки превосходит сумму минимального двузначного и максимального двузначного элементов последовательности.

В ответе запишите количество найденных троек чисел, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

with open('1717.txt') as f:
    data = list(map(int, f))

twos = {i for i in data if 10 <= abs(i) < 100}


def f(nums):
    twos = [i for i in nums if 10 <= abs(i) < 100]
    return len(twos) >= 2


ans = []
for elements in zip(data, data[1:], data[2:]):

    if f(elements) and sum(elements) > min(twos) + max(twos):
        ans.append(sum(elements))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие