ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17104. Типовая задача

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество пар последовательности, в которых остаток от деления хотя бы одного из элементов на 27 равен минимальному элементу последовательности.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента

with open('1719.txt') as f:
    data = list(map(int, f))

mn = min(data)

def f(nums):
    return nums[0] % 27 == mn or nums[1] % 27 == mn


ans = []
for elements in zip(data, data[1:]):
    if f(elements):
        ans.append(sum(elements))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие