ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17038. Резервная волна 2025

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от -100 000 до 100 000 включительно.

Определите количество пар последовательности, в которых только один из элементов является пятизначным числом, a квадрат суммы элементов пары превышает квадрат максимального пятизначного элемента последовательности, оканчивающегося на 37.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

with open('1715.txt') as f:
    data = list(map(int, f))

max_37 = max(i for i in data if
             10_000 <= abs(i) < 100_000
             and abs(i) % 100 == 37)


# Через исключающее или - ^
def f(x, y):
    return (10_000 <= abs(x) < 100_000) ^ (10_000 <= abs(y) < 100_000)


ans = []
for x, y in zip(data, data[1:]):
    if f(x, y) and (x + y)**2 > max_37**2:
        ans.append(x + y)

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие