ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17037. Основная волна 2025

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от -100000 до 100000 включительно.

Определите количество троек элементов последовательности, в которых не более двух из трёх элементов являются четырёхзначными числами, а сумма элементов тройки не больше максимального элемента последовательности, оканчивающегося на 25.

В ответе запишите количество найденных троек чисел, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

with open('1714.txt') as f:
    data = list(map(int, f))

max_25 = max(i for i in data if abs(i) % 100 == 25)


def f(nums):
    count_4 = sum(1_000 <= abs(num) < 10_000 for num in nums)
    return count_4 <= 2


ans = []
for elements in zip(data, data[1:], data[2:]):
    if f(elements) and sum(elements) <= max_25:
        ans.append(sum(elements))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие