ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17032. Апробация 2025

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество пар последовательности, в которых остаток от деления хотя бы одного из элементов на 16 равен минимальному элементу последовательности.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

with open('1700.txt') as f:
    data = list(map(int, f))

min_el = min(data)
answer = []

for x, y in zip(data, data[1:]):
    if x % 16 == min_el or y % 16 == min_el:
        answer.append(x + y)

print(len(answer), max(answer))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие