ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17031. Апробация 2025

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от –100 000 до 100 000 включительно.

Определите количество пар последовательности, в которых хотя бы одно число отрицательно,  а сумма чисел пары меньше количества чисел последовательности, кратных 32.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

with open('1705.txt') as f:
    data = list(map(int, f))

# Кол-во чисел, кратных 32
cnt_32 = len([i for i in data if i % 32 == 0])

ans = []
for x, y in zip(data, data[1:]):
    sum_xy = x + y
    if (x < 0 or y < 0) and sum_xy < cnt_32:
        ans.append(sum_xy)

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие