ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17033. Досрочная волна 2025

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от –100 000 до 100 000 включительно.

Определите количество троек элементов последовательности, в которых произведение максимального и минимального элементов тройки больше суммы всех отрицательных элементов последовательности.

В ответе запишите количество найденных троек, затем абсолютное значение максимальной из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

with open('1707.txt') as f:
    data = list(map(int, f))

sum_neg_nums = sum(num for num in data if num < 0)

ans = []
for num1, num2, num3 in zip(data, data[1:], data[2:]):
    elements = (num1, num2, num3)
    if max(elements) * min(elements) > sum_neg_nums:
        ans.append(sum(elements))

print(len(ans), abs(max(ans)))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие