ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16037. ЕГКР 2025

Алгоритм вычисления значения функции F(n), где n – целое число, задан следующими соотношениями:

F(n)=n при n < 20;
F(n)= (n-6) × F(n-7), если n ≥ 20

Чему равно значение выражения (F(47872) - 290 × F(47865))/F(47858)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n < 20 :
        return n
    else:
        return (n-6) * f(n - 7)


for n in range(20, 47872):
    f(n)

print((f(47872) - 290* f(47865))//f(47858))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие