ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16036. Досрочная волна 2025

Алгоритм вычисления значения функции F(n), где n – целое число, задан следующими соотношениями:

F(n)=1 при n ≤ 5;
F(n)= n + F(n-2), если n > 5

Чему равно значение выражения F(2126) - F(2122)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n <= 5:
        return 1
    else:
        return n + f(n - 2)


for n in range(1, 2126):
    f(n)

print(f(2126) - f(2122))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие