ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16015. Основная волна

Алгоритм вычисления значения функций F(n) и G(n), где n – целое число, задан следующими соотношениями:

F(n)= G(n-1) + G(n-3);
G(n)=3 × n, если n ≤ 9
G(n)=G(n-4) + 2, если n > 9

Чему равно значение выражения F(42999)?

from functools import lru_cache


def f(n):
    return g(n-1) + g(n-3)


@lru_cache()
def g(n):
    if n <= 9:
        return 3 * n
    else:
        return g(n - 4) + 2


for n in range(9, 42999):
    f(n)

print(f(42999))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие