ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16012. Типовые варианты

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=1 при n = 1;
F(n)= n + F(n-1) , если n чётно;
F(n)= F(n-1) + 2 × F(n-2), если n > 1 и при этом n нечётно

Чему равно значение функции F(19)?

def f(n):
    if n == 1:
        return n
    elif n % 2 == 0:
        return n + f(n - 1)
    else:
        return f(n - 1) + 2 * f(n - 2)


print(f(19))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие